Examples: You might have a function called foobar() in one spot and foo_bar() in another or FooBar() and the Java scheme fooBar(). This just makes things harder to follow IMHO.
This is trivial I know, but I've working on larger programs and this consistency makes for an easier read. I prefer the underscore method personally(foo_bar()) as it seperates the words for the function name. That's up to the dev team though.
One other small thing is spacing, it would make things easier to read again if the dev team used tabs instead of spaces for indenting. This will allow anyone to set tab spaces rather than having to deal with whatever the developer prefered.
Not all the PN files are like this, and I'm somewhat anal I guess, but it sure would make it easier to develop under PN with these small changes.
Great job, and keep up the good work.